An error occured when doing smooth

Dear prof. Yan,
 
(Matlab 2018b  Win10 , SPM8, DPABI_V4.0_190305, REST_V1.8_130615 DPARSF 4.4 advanced edition)
 
An error occured happened when I doing smooth. It got me confused that the smooth step have finished in some subjects, and generated a new file named "swCovRegressed_4DVolume", it's mean the smooth is done?
 
And other  subjects failed in Smooth. Here is the error information:
 
 
Running 'Smooth'
Failed  'Smooth'
错误使用 spm_conv_vol
File too small.
In file "F:\spm12\spm_smooth.m" (v4419), function "smooth1" at line 107.
In file "F:\spm12\spm_smooth.m" (v4419), function "spm_smooth" at line 37.
In file "F:\spm12\config\spm_run_smooth.m" (v3915), function "spm_run_smooth" at line 20.
The following modules did not run:
Failed: Smooth
错误使用 DPARSFA_run (line 3014)
Job execution failed. The full log of this run can be found in MATLAB command window, starting with the lines (look
for the line showing the exact #job as displayed in this error message)
------------------
Running job #1
------------------

出错 DPARSFA>pushbuttonRun_Callback (line 1795)
    [Error]=DPARSFA_run(handles.Cfg);
出错 gui_mainfcn (line 95)
        feval(varargin{:});
出错 DPARSFA (line 30)
    gui_mainfcn(gui_State, varargin{:});
 
错误使用 DPARSFA>UpdateDisplay (line 2271)
计算 UIControl Callback 时出错。
IdleTimeout has been reached.
Parallel pool using the 'local' profile is shutting down.
>>

 

Thanks.

 

AttachmentSize
Image icon error20190318.JPG96.17 KB

Forums:

You may try to remove all REST paths from matlab.

Thanks for your reply.

I tried many times. First, I added the Rest Paths and failed in smooth. Then, I remove other tools and only have dpabi and spm12, still failed.

In the result, some subject finished in the smooth and got a new file named  swCovRegressed_4DVolume.nii  

But other subjects still only have the raw file named "wCovRegressed_4DVolume.nii"

 

 

Then I may advise you to carefully check whether there is any Chinese character or spaces in matlab paths, then re-process your data with matlab installed with only dpabi and spm12, good luck!

Thanks Chen for your patience.
 
I checked  my paths and  re-process my data, but here are new error happened.
And I load up the anlaysis sets information in the attachments, can you help to check which set is worry?
Thanks
 
未定义变量 "Cfg" 或类 "Cfg.ParallelWorkersNumber"。
出错 DPARSFA_run (line 1461)
if isempty(gcp('nocreate')) && Cfg.ParallelWorkersNumber~=0
出错 DPARSFA>pushbuttonRun_Callback (line 1795)
    [Error]=DPARSFA_run(handles.Cfg);
出错 gui_mainfcn (line 95)
        feval(varargin{:});
出错 DPARSFA (line 30)
    gui_mainfcn(gui_State, varargin{:});
 
计算 UIControl Callback 时出错。

 

 

 

 

You setting seems OK. Take a wild guess, maybe simply filling in "Parallel Workers #:" on the left-bottom corner of the panel of DPARSFA can address this issue?

Download a newer version from https://github.com/Chaogan-Yan/DPABI again.